Home | Documentation | Atomic Chat | Github

Why can't I build for Android?



I’m getting that message:
The file ant.properties not found in /home/u001/AtomicProjects/Project1, unable to generate Release APK.

Here is my build settings:
Android SDK Path:
Android API Level - can’t select
Ant Path:
JDK Root:
Release Path:


Android API Level - can’t select, this means there may be a problem with the Android SDK installation. If you press the Refresh button next to the field, and wait a few seconds, does the button add some android options? If it does not change, there may be information in the Editor log file that reports a problem.
You need to be able to specify an Android API level, the minimum supported is android-10 for Atomic. These API levels are downloaded by the Android SDK, and you must select the ones you want.


After refresh there are versions appears. I selected 16. But still the same problem: unable to release APK.


To (successfully) build a Debug APK, uncheck the checkbox next to “Release Path” in the Android Build settings dialog box.
To build a Release APK, you must have a file named ant.properties somewhere, in this file you put :


And when the “Release Path” is checked and given a valid path to ant.properties, a fully certified release APK is generated.


Somewhere ? Could you tell a little bit more: where it comes from, where it should be (or where you have it).
I installed ant by apt-get. I tried to find ant.properties, don’t see it.


Sorry for the confusion, ant.properties is a file that you create, it’s purpose is to provide your certificate passwords, so it can be an automatic part of release APK deployment. You may put this file anywhere on your computer, like Documents, and then set the Android Build Release Path to that directory.
If you do not have a certificate to sign an APK, then you do not need the ant.properties file.


It works (if ant field left empty), thanks.
(By the way I tried Chickens, it’s refusing to work - just black screen. Basic3D example works though)


I tried the Chickens on my two androids, both came up, the old device took a long time to come up the 1st time, but then was fine. The 2nd device, an S4, the chickens came up, but the skybox was black. I had to scale the skybox textures down, and PR’ed the example to fix this.


I scaled down textures to 50% of the original size and it works now too. But I was unable to swipe camera.


Hmmm I cant move the camera either. Looking at the source code, it has no touch handling for mobile to make the camera move (despite the video evidence).