Home | Documentation | Atomic Chat | Github

It was once successful, but not now


#1

It was once successful, but not now. I can not find the cause.

/home/buster/atomic/AtomicGameEngine/Artifacts/Build/Source/Generated/CSharp/Packages/Atomic/Managed/CSModuleGraphics.cs(3373,7): warning CS1587: XML comment is not placed on a valid language element
/home/buster/atomic/AtomicGameEngine/Artifacts/Build/Source/Generated/CSharp/Packages/Atomic/Managed/CSModuleGraphics.cs(11119,7): warning CS1587: XML comment is not placed on a valid language element
/home/buster/atomic/AtomicGameEngine/Artifacts/Build/Source/Generated/CSharp/Packages/Atomic/Managed/CSModuleAtomic2D.cs(2752,7): warning CS1587: XML comment is not placed on a valid language element
/home/buster/atomic/AtomicGameEngine/Script/AtomicNET/AtomicNET/ThirdParty/MiniJSON.cs(399,26): warning CS1572: XML comment has a param tag for 'json', but there is no parameter by that name
/home/buster/atomic/AtomicGameEngine/Script/AtomicNET/AtomicNET/ThirdParty/MiniJSON.cs(401,47): warning CS1573: Parameter 'obj' has no matching param tag in the XML comment for 'Json.Serialize(object)' (but other parameters do)

Errors:

/home/buster/atomic/AtomicGameEngine/Artifacts/AtomicNET/Build/AtomicNET.sln (default targets) ->
(Build target) ->

/home/buster/atomic/AtomicGameEngine/Artifacts/AtomicNET/Build/AtomicNET.Android.SDL/AtomicNET.Android.SDL.csproj: error : /home/buster/atomic/AtomicGameEngine/Artifacts/AtomicNET/Build/AtomicNET.Android.SDL/AtomicNET.Android.SDL.csproj: /home/buster/atomic/AtomicGameEngine/Artifacts/AtomicNET/Build/AtomicNET.Android.SDL/AtomicNET.Android.SDL.csproj could not import "$(MSBuildExtensionsPath)\Xamarin\Android\Xamarin.Android.Bindings.targets"

 69 Warning(s)
 1 Error(s)

Time Elapsed 00:00:03.8552540

Compilation Command: -c mono “/home/buster/atomic/AtomicGameEngine/Build/Managed/nuget/nuget.exe” restore “/home/buster/atomic/AtomicGameEngine/Artifacts/AtomicNET/Build/AtomicNET.sln” && “xbuild” “/home/buster/atomic/AtomicGameEngine/Artifacts/AtomicNET/Build/AtomicNET.sln” /p:Platform=“Any CPU” /p:Configuration=Release

NETBuild Error for solution: /home/buster/atomic/AtomicGameEngine/Script/AtomicNET/AtomicNETProject.json
/home/buster/atomic/AtomicGameEngine/Build/node_modules/jake/lib/api.js:340
throw errObj;
^

Error: Process exited with error.
at api.fail (/home/buster/atomic/AtomicGameEngine/Build/node_modules/jake/lib/api.js:336:18)
at null. (/home/buster/atomic/AtomicGameEngine/Build/node_modules/jake/lib/utils/index.js:124:9)
at emitTwo (events.js:87:13)
at emit (events.js:172:7)
at ChildProcess. (/home/buster/atomic/AtomicGameEngine/Build/node_modules/jake/lib/utils/index.js:227:20)
at emitTwo (events.js:87:13)
at ChildProcess.emit (events.js:172:7)
at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
buster@MDCT:~/atomic/AtomicGameEngine$


#2

I have the same error