Home | Documentation | Atomic Chat | Github

Issue with marking for Inspector


#1

I’m having some issues with marking properties for the Inspector, I had it working for a while, then suddenly, I added another script to my project and it no longer works. I checked and for other projects it works fine, but for my main project it has completely stopped.

Here is the Syntax that I’ve been using:

using System;
using AtomicEngine;

public class DemoLevel : CSComponent
{
    [Inspector]
    string GoalNode = "GoalNodeName";
    [Inspector]
    string ResetPositionNode = "NodeName";
    [Inspector]
    float rX = 0f;
    [Inspector]
    float rY = 0f;
    [Inspector]
    float rZ = 0f;

    RigidBody body;

    Input input = GetSubsystem<Input>();
    void Start()
    {
        body = Node.GetComponent<RigidBody>();
    }
    //It goes on a little bit
    ///... ... ...
}

And this component and others like it worked.
Now, even components that worked no longer do. Even Spinner doesn’t show “Speed”. I don’t know what to do.


#2

I’ve had this in the past when the service that generates metadata about a dll fails for some reason. In our case is was that default values for come types didn’t get handled well. It can also happen if the AtomicNETService is failing for some reason. Have you perhaps had any errors or dialogs related to the service?