Home | Documentation | Atomic Chat | Github

Importing 3D Assets


I’ve read that you can import 3D objects into AGE via drag and drop. But I’ve read or seen little more deatil.

Rather than play detective myself, could someone tell me …

  1. What 3D mesh formats are supported for drag and drop? 3DS? OBJ? FBX?
  2. Can I also place assets directly in project folder via the OS desktop to import them?
  3. Are textures imported as well? Whole scenes?



For what it’s worth, I’ve tried dropping an FBX model (that works in other game engines) into an AGE project. It shows up in the Models folder but when instanced to the scene appears to be an empty node.

Clearly, I’m missing something. :wink:


There is a wiki page that answers some of your questions https://github.com/AtomicGameEngine/AtomicGameEngine/wiki/Changing-how-models-are-imported . Drag and drop to the Editor does not work for Linux at the moment, the work around is to drag and drop the files in the OS. On Win and Mac both Drang and drop methods work.
Most assets types can be moved into the project in this way, the 3d model formats it will convert are : fbx, obj, blend, x, dae, 3ds, ms3d
Currently, the assimp library is used to convert the major model 3d formats, but it is not very good about reporting if the conversion worked or not. It can do FBX, as some of the examples demonstrate, but my experience has been it does not like older FBX and will silently fail, I now use the free (win,mac) Autodesk FBX converter to get a verison that assimp will successfully convert until assimp can do the job without it.
Other ways of getting models into AGE, is by using the Urho3D AssetImporter, which is a command line utility, so very hands on. And there is a Blender exporter https://github.com/AtomicGameEngine/AtomicGameEngine/wiki/Blender-to-Atomic-Game-Engine-Mesh-Exporter , which is a little less hands on.


Sorry, I know this post is old but I had the same problem. Your model appears to be an empty node because, from my experience, the scale of the model gets messed up while importing. I scaled mine to I think 1/100 before I could see it, but I don’t remember the exact number. I hope you figured it out before I posted this and good luck with your development!