Home | Documentation | Atomic Chat | Github

Depth issue in editor


I built Atomic for the first time today to try it out, but immediately ran into a depth issue in the 3D view. I’m running the newest version on Ubuntu 16.04 LTS with the open source Radeon driver.
This is a screencap of the character and physics example to show what I mean.

This happens from all camera orientations, though sometimes it flashes between that and correct depth when the camera moves.
However, it works completely fine when I run the game. It’s just an issue in the editor and makes it really hard to do anything.


Could you please try running the editor with the -gl2 argument? For example, from the command line in the editor folder, run the command “./AtomicEditor -gl2”. This could be a problem with zbuffer due the fact that in the editor the scene is not rendered to a framebuffer. That argument forces OpenGL 2 which could fix that problem. We have a number of reports on similar problems so you can rest assured the developers are doing their best to fix that.


That completely solved the issue for now, thank you.


You’re welcome :slight_smile:. I’m glad it worked. Hopefully that argument won’t be necessary soon.