Home | Documentation | Atomic Chat | Github

Can't import animated FBX


#1

I’m doing some tests with some Mixamo models. Mixamo can only output as a base mesh with bones and the animation files are separate.
Method 1: import the base model (fbx) and animations (fbx). Try to attach the animations to the base mesh in the AGE editor. No combination of fiddling will make this work. No animations will show up. In fact, the imported skeliton/animations don’t even show an animation available.

Method 2: Merge all the animations to the base mesh using Fragmotion and export a new fbx. This works fine. but I need to up-convert the fbx format from 2009 to 20012/13. This works fine too and inside the official Autodesk fbx conveter tool, I can see the mesh playing all the animations. However after importing to AGE, still no animations attached to mesh. This goes too for a collada file with the same animations. However the imported Collada file has the mesh positioned in the first frame of the first animation.

Is there any way I get my animated models into AGE?
Thanks!


#2

So i’m guessing that if you want to have animated models in your game, you have the choice of either a small robot or a monster in blue-jeans, because nothing else works.

btw: This is how game engines die. The internet is littered with the corpses of game engines where the fundamentals were ignored in favor of chasing the screenshots of AAA engines.


#3

if you’d like to be successful, I’d recommend using Urho3D’s AssetImporter. This thread explains much about what it sounds like you are trying to do https://discourse.urho3d.io/t/ready-to-use-models-with-animations/2147


#4

And check this (it is using asset importer with gui)


#5

Thanks for the reply, But I’m not sure what I’m to do with this app.
My model is already correct, with animations.
This seems to be a tool for viewing models, decomposing them and/or packaging them into some kind of xml prefab.
My problem is that Atomic can’t read animations inside of an fbx file and can’t seem to attach animations to a mesh from another animation fbx file.
I tried it anyway and decomposed the model into a single '.mdl. file and several ‘.ani’ files. I can load the mesh into the scene and the animations show up in the project tree right next to the mesh, but under the animation controller there are no animations to attach to the mesh.
I also tried the mutant model as a test and no animations show up for that either despite working with the mutant sample project. I might be doing something wrong, but because there is ZERO manual or documentation, i have no idea what that would be.

Thanks