Home | Documentation | Atomic Chat | Github

Build_AtomicEditor.sh command not found



I’m trying to use Atomic Engine, but sadly, my old computer does not have support to it (I get ERROR: shader model 3.0 display adapter is required).
Then I’m trying to use Linux Mint.
I followed the “Detailed instructions for building on Linux” but when I do Build_AtomicEditor.sh
I get “Command not found”.

I am not a advanced Linux user, then I don’t know if I did something wrong.

I need help, please!

Thanks in advanced!



Did you include “sh” in the beginning of the command?

It should look like this:

sh Build_AtomicEditor.sh

About that shader model error, I think it might be because of an outdated graphics card or driver, perhaps.
EDIT: The wiki showed the wrong command, fixed now :dancer:


You can also use ./Build_AtomicEditor.sh which I think is the Linux convention for this? @CTrauma care to weigh in on that statement? :slight_smile:


Thanks by the quickly reply! Now I have some progress, but I’m getting a message “sh: 0: Can’t open Build_AtomicEditor.sh” :grin:

And if I use ./Build_AtomicEditor.sh I get “file or directory not found”.

I’m using Linux Mint 17.3 - 64bits

I tried with a 32bits version too.


Did you cd into the correct directory?

When you’ve used

git clone --recursive https://github.com/AtomicGameEngine/AtomicGameEngine

…change directory by using

cd /path_to_directory

(I think the default path is something like /home/user/AtomicGameEngine).
When you’ve changed directory, you should be able to use sh Build_AtomicEditor.sh.


Now it works! Thank you so much!
I think it would be very helpful for someone if you add this information on the wiki because Linux is a unknow place for people like me! :sweat_smile:

Btw, my card is the bad SiS672 that is the why it does not supports Atomic Engine (and nothing else) :joy:

Thank you again!


Glad you could make it work :clap:
I’ll have a look at making this information a bit more clear on the Wiki.